• Inicio

  • This is the forum index page
Foro de ayuda y uso del wordpress.
 #12821  por fgrauorellano
 31 Ago 2018 08:53
Buenas tardes:

Estoy creando un multisite por primera vez y me surge un problema:

He cargado el WP en un dominio llamado .net que está en mi hosting con ustedes, porque pretendo crear un multisite en esta página cuyo dominio principal apunte a USA

A continuación he puesto en marcha la opción de red del multisite para ese dominio, y he creado dos subdominios en el escritorio del WP de losclaros.net . Por tanto en ese momento tenía 3 sites llamados:
midominio.net para crear el multisite
en.midominio.net para la versión en inglés
es.midominio.net para la versión en español

Después he intentado entrar en los escritorios WP de cada uno de esos 3 sites del multisite, pero sólo podía entrar en el administrador WP de midominio.net y me daba error para entrar en los dos subdominios.

He pensado que era porque no había creado previamente los subdominios en el hosting. He llamado al servicio técnico para preguntar a un técnico y me ha dicho que, efectivamente, primero debo crear los dos subdominios.

He vuelto al escritorio de WP del multisite de midominio.net, he borrado los dos subdominios creados en el multisite dejando solo midominio.net.

Después he ido al Plesk y he creado los subdominios como me ha indicado vuestro técnico (porque el dominio .net ya estaba creado y funcionaba):
en.midominio.net
es.midominio.net

Luego he ido al escritorio de WP de midominio.net y he vuelto a crear los dos subdominios en el WP del multisite, y al intentar entrar en los respectivos escritorios me devuelve error 404.

¿Pueden decirme qué puede estar ocurriendo y cómo resolverlo?

Muchas gracias.
 #12827  por Jlramirez
 31 Ago 2018 12:55
Estimado usuario,

Cuando se habilita el multisite de Wordpress, este crea dentro de la pestaña Herramientas aparece la herramienta para poder crear los subdominios pero dentro del escritorio del dominio losclaros.net no vemos esa heramienta.
¿Nos podría decir como a creado los subdominios?

Un saludo.
 #12828  por fgrauorellano
 31 Ago 2018 13:43
Gracias.

Había marcado la casilla para recibir un email cuando ustedes me responden a mi consulta, pero no he recibido ningún email. Paso a contestar:

En el admin de wp he ido a: HERRAMIENTAS - CONFIGURACIÓN DE LA RED - CREAR UNA RED DE SITIOS - SUBDOMINIOS

Luego me ha dado 2 grupos de instrucciones: Uno para el wp-config y otro para el .htaccess

Después he ido al escritorio del WP, he refrescado, y ya me aparecía la opción de MIS SITIOS arriba a la izquierda:

MIS SITIOS - ADMINISTRADOR DE LA RED - SITIOS - AÑADIR NUEVO

Entonces he creado los dos subdominios en.losclaros.net y es.losclaros.net que previamente había creado en Plesk.

Lo que me extraña es que la pantalla de error me dice esto que hace referencia al dominio losclaros.es en lugar del dominio losclaros.net con el que siempre he trabajado:
Not Found
The requested document was not found on this server.
Web Server at losclaros.es

Adjunto pantallazo de: 1. la creación de los subdominios y 2. del error.
No tienes los permisos requeridos para ver los archivos adjuntos a este mensaje.
 #12839  por Jlramirez
 31 Ago 2018 18:06
Estimado usuario,

Pruebe creando un .htaccess con el siguiente código:

RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]

# add a trailing slash to /wp-admin
RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
RewriteRule . index.php [L]

El otro archivo .htaccess puede modificar el nombre a _.htaccess para así coja la configuración del archivo que ha a creado.

Un saludo.
 #12843  por fgrauorellano
 01 Sep 2018 08:43
Ok. Pero antes, ¿saben ustedes la razón por la que la carpeta de losclaros.net me figura dentro de la carpeta de losclaros.es en el FTP? Adjunto pantallazo obtenido cuando he ido a modificar el .htaccess que me han dicho en losclaros.net

Son dos dominios distintos y separados. No lo entiendo. Durante un tiempo había una redirección desde losclaros.net a losclaros.es, y esa es toda la relación que se supone que ha habido entre ellos.
No tienes los permisos requeridos para ver los archivos adjuntos a este mensaje.
 #12845  por fgrauorellano
 01 Sep 2018 18:50
He hecho lo que me han dicho con el .htaccess pero no funciona. Adjunto pantallazos de:
1. Plesk con nuevo .htaccess para losclaros.net y antiguo _.htaccess anulado. Donde también se ven las carpetas de los 2 subdominios en. y es.
2. Plesk: Contenido del nuevo . htaccess que me han dicho
3. Escritorio del administrador WP del multisitio losclaros.net con los 3 sitios que contiene: losclaros.net , es. , en.
Puedo abrir el administrador WP de losclaros.net pero sigo sin poder abrir el de es. y en.

Gracias.
No tienes los permisos requeridos para ver los archivos adjuntos a este mensaje.