• Inicio

  • This is the forum index page
Consultas sobre instalación de modulos y problemas con módulos.

Moderador: Antonio Torres

 #9517  por Fer
 12 Mar 2018 19:23
Buenas tardes
Cuando intento acceder a los modulos a traves del backoffice de prestashop me sale este error:
[PrestaShop] Fatal error in module file :/var/www/vhosts/decorer.es/estoresdecor.com/modules/blockreassurance/blockreassurance.php:
Interface 'PrestaShop\PrestaShop\Core\Module\WidgetInterface' not found

he borrado el modulo en cuestión y me da error en otro módulo y así seguidamente.

La página es www.estoresdecor.com
La versión de Prestashop es: 1.6.1.11
El tema es Leo clothes
Todo lo demás parece funcionar correctamente, pero no puedo acceder a este apartado de los modulos.
Última edición por Fer el 18 Mar 2018 10:06, editado 1 vez en total.
 #9519  por Jose_90
 13 Mar 2018 09:17
Estimado usuario,

Por el error que esta arrojando parece que falten o estén corrompidos algunos ficheros, intente restaurar un backup de ficheros o si no tiene ninguno reciente solicite por un ticket al departamento de soporte técnico un backup de los ficheros de ese dominio.

Si puede indiqueles en que día le empezó a dar el error por si tuvieran un backup de ese día o el de antes.

Un saludo.
 #9598  por Fer
 15 Mar 2018 16:11
Del departamento de soporte técnico me derivan a este foro nuevamente, porque las copias de seguridad son todas recientes y el problema viene de algún mes atras.
Si podemos hacer algo para intentar solucionarlo y si no haremos una instalación nueva y salvaremos lo que podamos.
Cualquier idea será bien recibida.
Gracias
 #9601  por Jose_90
 15 Mar 2018 16:37
Estimado usuario,

Por lo visto parece que viene provocado por un bug de prestashop que hace que algunos modulos se muestren como disponibles para la versión 1.6 pero en realidad se instala la versión de prestashop 1.7, corrompiendo por completo el funcionamiento.

Le dejo un enlace con mas información:
https://www.prestashop.com/forums/topic ... -any-more/

La solución finalmente recae en ir borrando de forma manual la carpeta de los modulos que provocan error, si son debidos al fallo comentado anteriormente, deberías tener carpetas llamadas ps_"nombremodulo" dentro de la carpeta /modules

Si quiere que nosotros reparemos el problema tendría que mandar un correo a desarrollo@profesionalhosting.com solicitando un presupuesto por la reparación.

Un saludo.