• Inicio

  • This is the forum index page
Consultas sobre otros problemas y errores.
 #5385  por amalio.gomez.bop
 Mié Abr 19, 2017 6:35 pm
Hola,
hace unas semanas me cambiaron el VPS a uno superior.
La web ya está funcionando, pero hay un problema. Para poder añadir imágenes a las entradas nuevas, tanto destacadas como dentro de los artículos, he de cambiar el tema y desactivar un plugin.
Si no hago esto antes, al intentar insertar una imagen Wordpress se queda buscando... indefinidamente.
Lo mismo sucede al intentar añadir un link interno. Nunca encuentra links relacionados en la línea de enlaces para insertar.
Sin embargo, sí deja ver la galería desde fuera de las entradas y también permite subir imágenes... aunque no se vean al subirlas, no desde la nueva entrada en modo edición.

Parece ser un problema con el tema actual (hecho con Bones). Hemos probado a usar versiones anteriores, importadas del otro servidor, pero sucede lo mismo. Creo que es un problema de compatibilidad con algún plugin viejo (creo que el problema lo da el de reparto de claves Keys Giveaway). Pero necesito este plugin y no encuentro uno que haga la misma función (permite subir una lista de claves y las asigna por email a usuarios que introducen un código que cambiamos cada mes).

La solución puede pasar por:
- Modificar el que falla .
- Sustituir el plugin.
- Localizar el fallo en el tema y solucionarlo.
¿Otro?

Gracias
 #5391  por Juan82
 Vie Abr 21, 2017 9:58 am
Estimado usuario:

Para saber la causa el error es importante saber si antes de que cambiara de VPS funcionaba correctamente la web. También si este error viene a consecuencia de una actualización de wordpress, instalación/actualización de nueva plantilla o plugins.

Para depurar el problema le recomiendo:
- Desactivar plugins de seguridad, cache limpiar dicha cache.
- Para comprobar si es problema de plugins puede desactivarlo todos o renombrar la carpeta plugins y probar si funciona la carga de imágenes.
- Si el problema es de un plugins tendrá que actualizarlo o desinstalarlo sino hace uso. Es importante comprobar para que versión de wordpress en compatible el plugins.
- Si continua con el problema puede que sea tema de la plantilla, en ese caso pruebe con otra plantilla si funciona correctamente.
- Si el problema es la plantilla compruebe para que versión de wordpress es compatible la plantilla, pruebe si existe alguna actualización de su plantilla. También puede realizar una prueba de sobre un wordpress con la misma versión limpio si funciona la plantilla, y en ese caso probar a volver a subirla a su web.
- Si el problema persiste ya haría falta conocimientos de programación activar el modo debug de wordpress e intentar solucionar el problema accediendo al código fuente.

Si quiere que lo hagamos nosotros con pack de horas o presupuesto escriba un ticket a desarrollo@profesionalhosting.com

Nota: antes de realizar prueba y cambios le recomendamos haga un backup de la web para prevenir errores y perdida de información.

Un Saludo.
 #5414  por Juan82
 Lun Abr 24, 2017 3:09 pm
Estimado usuario:

Hemos encontrado el error se debía a que algunos archivos tenían una codificación incorrecta. Lo hemos cambiado y ahora carga correctamente las imágenes.

Este error se debe a que a la hora de generar los archivos, o tras alguna modificación no se guardo con la codificación adecuada.

Un Saludo.